Tags   Printing  

Special message for XP and IE8 users

Hey XP and Internet Explorer 8 users!  Have you heard the news about our new coupon printing software? Maybe you noticed that Internet Explorer 7 and 8 are no longer on the support list.  Maybe you tried to install the software using IE8 and it didn’t work.  Maybe you’re asking, “What gives, RedPlum??”

Not to worry! XP users can still print coupons using Chrome or Firefox browsers, which will continue to offer browser security updates to XP users.  

XP users should first make sure they have Microsoft’s .NET 4.0 framework installed BEFORE you install Print@Home.  If you have a lower version of .NET (such as 2.0 or 3.5), you will need to upgrade.  To check for .NET Framework:

  • Click the Start Menu and select Control Panel
  • Click Add/Remove Programs
  • Wait for the list to populate, then scroll through to find .NET.

If you do not have .NET 4.0 installed, or if you have an older version, you can find more information and a download link HERE.   

Next, download and install Chrome or Firefox, then download the Print@Home coupon printing software.  Click here for detailed instructions

Vista and Windows 7 users, upgrade your Internet Explorer browser to the latest version to take advantage of improved security and better feature support.